* バグ報告 [#v0b81dea]

> 使用中に発生した例外等で、エラーログをはき出せなかった場合や、エラーログをアップロードした際にご報告下さい。&br;
&size(30){&color(red){過去の報告は[[こちら>http://www.wikihouse.com/nicoAE/index.php?%A5%D0%A5%B0%CA%F3%B9%F0]]};};&br;
&br;
エラーログは ''NicoVisualEffects.exe'' があるフォルダ内に ''errorlog.xml'' という名前で保存されます。&br;
エラーが発生した場合、バージョンが最新であるかどうか確認し、最新でない場合は最新版に更新した後、再現するかどうか確認してください。&br;
ファイル読み込みやタイムラインへの配置時にエラーが発生した場合、エラーログ
の下にファイルの詳細(ツールで取得したもの)も記述して下さい。&br;
情報取得ツール:[[真空波動研>http://kurohane.net/]]、[[MMname2>http://page.freett.com/HarryTools/index.html]]&br;
エラーログのアップロードは[[こちら>http://www9.uploader.jp/home/nicoAE/]]からお願いします。&br;
&br;
書き込む前に、今までの書き込みやこちらに同じような現象がないか確認して下さい。:[[FAQ]]&br;
&br;
#article
**ドロップシャドウの影をぼかすと本体がずれる? [#l19f96e7]
>[[YO]] (2009-01-21 (水) 21:14:25)~
~
NiVE 1.78を使用しています。~
ドロップシャドウエフェクトを使用して、ぼかした影を回転させると~
特定の角度で本体が動いてしまうようです。~
プロジェクトを以下の場所においておきます。~
http://www.mediafire.com/download.php?mnjimm0nxjy~

//
- 確認しました。 これは描画時のアンチエイリアスによるもので、バグというより仕様です。 一応動かないようにはできますが、陰の距離が近い場合に動きがカクカクになりますがよろしいでしょうか? -- [[うp主]] &new{2009-01-22 (木) 00:17:37};
- 回答ありがとうございます。仕様と言うことならそういうものと考えます。GIMPのドロップシャドウみたいに、距離ゼロでぼかしドロップシャドウを入れて、まわりがぼおっと光るような感じにしたいというのが元々の話だったのですが、動きがカクカクになるということであれば仕方ないかなと。 -- [[YO]] &new{2009-01-22 (木) 06:44:40};
- 周りが光っているような表現には、ドロップシャドウを陰の距離0で掛けるよりも、膨張を使って境界線をぼかした方がズレもなく、簡単に同じような表現ができると思われます。 -- [[うp主]] &new{2009-01-22 (木) 14:43:34};

#comment

**トラックマットのアルファマットが2値判定 [#u47bc3d3]
>[[金の髭]] (2009-01-13 (火) 23:45:44)~
~
ちょこまかとすみません。NiVE v1.78使用。~
トラックマットでマットに「アルファ」を指定した場合、アルファ値が「0」「0以外」の2値でしか判定されていないようです。~
例えばGIMPで白から透明に変化するグラデーションを作ってアルファマットとして画像に適用したところ、~
アルファが0の部分しか表示されませんでした。~
(白から黒に変化するグラデーションをルミナンスマットとして適用した場合は~
 狙いどおりグラデーション状にマットがかかります。)~

//
- 確認しました。トラックマットは、リサイズ時にColorMatrixでマスクを作成しているのですが、行列の要素を0にし忘れたところがあったため2値判定になってしまっていたようです -- [[うp主]] &new{2009-01-14 (水) 10:04:49};

#comment

**テキストからExecuteExpression()を実行した時の挙動 [#hd6cef76]
>[[金の髭]] (2009-01-13 (火) 00:04:08)~
~
NiVE v1.78使用。テキストマテリアルのエクスプレッションにExecuteExpression()を呼び出すコードを書くと、~
その後マテリアルやエフェクトのエクスプレッションを書こうとした際に例外が発生します。~
再現手順やエラーログは[[こちら>http://www9.uploader.jp/dl/nicoAE/nicoAE_uljp00069.zip.html]]にまとめて上げてあります。~
コードの書き方を間違ってるかもしれないので、もしそうならご指摘いただければ幸いです。~

//
- 確認しました。エラーレポートウインドウが出てくるのは2つ下の通りで、今回のはIExpressionComposition.ExecuteExpression()実行時に、生成したファイルからAssemblyインスタンスを作る際にFileIOPermissionが引っかかってたようです。 -- [[うp主]] &new{2009-01-13 (火) 15:43:53};

#comment

**ブレンド先へのエクスプレッションが適用されない問題 [#gf71a56a]
>[[167]] (2009-01-11 (日) 12:34:37)~
~
NiVE ver1.78使用~
オブジェクトAにブレンドTエフェクト適用し、オブジェクトBをブレンド。~
Bのトランスフォームの不透明度からエクスプレッションで点滅させたが点滅せず。~
直接キーフレームを打った場合は点滅する。~
~
回避法としてAのブレンド率で点滅させれば可能ですが、バグだと思いますので報告。~

//
- 確認しました。ITimeline.GetImage()の処理部分をエクスプレッション追加時に変更し忘れてました(ずいぶん前だな) orz -- [[うp主]] &new{2009-01-12 (月) 13:54:14};

#comment

**テキストとアニメータのエクスプレッションでのエラーの出方 [#g894b60a]
>[[金の髭]] (2009-01-09 (金) 00:36:16)~
~
テキストマテリアルやアニメータのエクスプレッションで、例えば~
  MonitorProperty.Add(null);~
という感じでエラーを出すと、~
  'nicoAE.Expression.ExpressionException'型のオブジェクトを~
   逆シリアル化するコンストラクタが見つかりませんでした。~
というエラーウィンドウのあと、~
  キャッチされない例外'nicoAE.Expression.ExpressionException'~
のウィンドウが出て終了か継続かを確認されます。~
一応エラーログを[[こちら>http://www9.uploader.jp/dl/nicoAE/nicoAE_uljp00068.xml.html]]に上げておきました。~
マテリアルやエフェクトのエクスプレッションでは「評価中にエラーが発生しました」と出て~
一時的にエクスプレッションが評価されなくなるだけでした。~

//
- 確認しました。テキストアニメータ関連のエクスプレッションの例外処理部分がうまく機能していないのが原因でした orz また、ExpressionExceptionでもGetObjectData等のオーバーライドし忘れがあったようです orzorz -- [[うp主]] &new{2009-01-09 (金) 13:18:48};

#comment

**エクスプレッション関係で色々 [#za229c8d]
>[[金の髭]] (2008-12-29 (月) 08:54:52)~
~
1.テキストアニメータのプロパティを右クリックして「クリップボードに厳密コピー」した時の表現が一部間違っているようです。~
   ●厳密コピーした時の表現~
     ExpressionUtils.GetProperty(ExpressionUtils.GetItem(((IExpressionAnimator)Property.This),Material.GetAnimator(), 1961245682).Properties, "位置");~
  "Material"の前がピリオドではなくカンマになってしまっています。~
~
2.「エクスプレッションについて.txt」にあるExpressionUtils.GetComposition()が存在しないようです。~
  ループで回してコード比較すればいいので問題ないですが一応ご報告しておきます。~
~
3.「プラグイン開発について.txt」のStringPropertyのコンストラクタの説明で~
  defaultPropの型がboolと書かれているようです。~

//
- ぎゃぁぁぁぁあああああ orz 確認しました。 ExpressionUtils.GetComposition()はなぜかGetItemのオーバーロードになっていました orz 修正まではそちらを使用してください。 -- [[うp主]] &new{2008-12-30 (火) 02:07:49};

#comment

**書き出し時にエラー [#r78b5079]
>[[lake]] (2008-12-24 (水) 14:25:19)~
~
エラーログ→http://www9.uploader.jp/dl/nicoAE/nicoAE_uljp00062.xml.html~
1.77で動画をDivXで書き出そうと思ったらなぜか失敗します~
~
情報不足かもしれませんが原因がよくわからないので~
確認をお願いします~

//
- XviDでもあるようなのですが、VFWOutputではいくつかのコーデックでのAVIの書き出しができないようです。一度別のコーデックか、無圧縮で書き出してAVIUtlなどで圧縮するようにしてください。 -- [[うp主]] &new{2008-12-24 (水) 21:05:25};
- わかりました ありがとうございます -- [[lake]] &new{2008-12-25 (木) 15:02:56};

#comment

**読み込み済みアイテムを読み込んだ後保存できなくなる [#h974b4cd]
>[[コーヒー]] (2008-12-16 (火) 09:57:32)~
~
いつも使わせていただいております。~
~
エラーログ→http://www9.uploader.jp/dl/nicoAE/nicoAE_uljp00060.xml.html~
~
ver1.77にて、ImageInputから1枚の画像を取り込み、その後その画像を含む複数枚の画像を取り込み、「すでに開かれています」のエラーメッセージが出て残りの画像が読み込まれた段階で保存しようとすると~
System.ArgumentException~
が発生しました。~
保存は実行されないようなので、これはちょっとコワいかも・・・。~
~
確認よろしくお願いいたします。~

//
- 確認しました。複数同時読み込み時にすでに読み込んだファイルがあると、その手前の入力プラグインをDisposeしてしまっていました orz -- [[うp主]] &new{2008-12-16 (火) 20:21:45};

#comment

**テキストプリセットが保存されない問題 [#wbb941f1]
>[[167]] (2008-12-10 (水) 21:17:17)~
~
ver1.76使用。~
プロジェクトによっては、テキストプリセットを保存して閉じて、再度開くと~
アイテム欄自体からテキストプリセットが消えてしまいます。~
ハッシュ値MD5でチェック。~
■保存されないプロジェクト~
追加前~
23e82d75247a17a7bc99e981ecfb1888~
~
アイテム欄にテキストプリセットを追加して保存~
2f0e2f09bf3e2260e549b5b289ffb458~
~
NiVE閉じる~
2f0e2f09bf3e2260e549b5b289ffb458~
~
NiVE開く(テキストプリセットが消えている)~
2f0e2f09bf3e2260e549b5b289ffb458~
~
■保存されるプロジェクト~
追加前~
04a8a12ac0c2bd694eb972912609c92e~
~
テキスト追加して保存~
23f0b43892a7f517ddfa2d8eea6f0f93~
~
閉じる~
23f0b43892a7f517ddfa2d8eea6f0f93~
~
開く~
23f0b43892a7f517ddfa2d8eea6f0f93~
~
再度開く際に問題の模様です。~
なお問題のプロジェクトでも動作中の作業自体は可能です。~

//
- 上の2つのプロジェクト http://www9.uploader.jp/dl/nicoAE/nicoAE_uljp00053.zip.html -- [[167]] &new{2008-12-10 (水) 21:24:23};
- 確認しました。 どうやら、カメラを先に作成してからテキストを作成すると保存はされますが、読み込み時にテキストはすでに読み込まれたものとして処理されてしまっていたようです orz -- [[うp主]] &new{2008-12-11 (木) 00:14:36};
- 1.77で修正ありがとうございます。 -- [[167]] &new{2008-12-14 (日) 00:11:42};

#comment

**音声アイテムの入れ替えでエラー [#he333eb5]
>[[コーヒー]] (2008-12-03 (水) 04:52:55)~
~
エラーログ→http://www9.uploader.jp/dl/nicoAE/nicoAE_uljp00052.xml.html~
~
ver1.76にて、タイムラインの音声アイテムを「アイテムの入れ替え」で入れ替える際、候補の中にcompのアイテムも挙げられていて、それを選択すると~
System.InvalidCastException~
が発生しました。~
以前Videoアイテムの入れ替えであったのと似たような感じでしょうか。~
確認よろしくお願いします。~

//
- 確認しました。 入れ替えできるアイテムの抽出時の条件があいまいだったために洗濯できないアイテムまで選択できるようになってしまっていました -- [[うp主]] &new{2008-12-04 (木) 09:32:10};

#comment

**出力時エラー [#n5403eac]
>[[167]] (2008-11-27 (木) 21:14:54)~
~
NiVe1.74〜1.76で確認。~
640×480 30fpsの175frのプロジェクトの途中で書き込み中にエラーが発生。~
種類'System.OutOfMEmoryException'の例外がスローされましたとなります。~
http://www9.uploader.jp/dl/nicoAE/nicoAE_uljp00048.xml.html~
最後の数フレームがない状態のものが出力されてしまう状態です。~
カラーイメージだけの300frで試したものは問題なく出力されます。~
自分では区別付かないので、↓のたわさんと同様の内容でしたらすいません。~

//
- エラーログからするとちょっと違いますね。場所は似たようなところだけど… どちらもまだ再現できてないので原因はつかめてません。旧wikiにある1.73以前だとどうでしょうか? -- [[うp主]] &new{2008-11-28 (金) 20:44:59};
- 問題のプロジェクトは、古いverで対応してませんと出てしまいました。 -- [[167]] &new{2008-11-30 (日) 22:19:51};
- うーん… では、コンポジションの構成とかはどうなっていますか?他にいくつかOpenGLなコンポジションとかもネストしてますでしょうか? -- [[うp主]] &new{2008-12-02 (火) 13:23:58};
- ネストと言うのは出力するコンポに、他のコンポが含まれるかという意味であってますか?出力するOpenGLのコンポの中に他のOpenGLのコンポが3個とGDIのコンポが2個含まれます。ググってもプログラム用語やら釣り用語ばかりなので、間違ってましたらお手数ですが、指示いただけると助かります。 -- [[167]] &new{2008-12-02 (火) 19:57:30};
- 中々再現しない… orz そういえば昔うpされていたサンプル(sm4546125)のプロジェクトを実行したときにまれに同じようなエラーを見た気がしたので再度実行してみましたが、グラボを積み替えていたのも合ってか再現できず。 もしかしたらPCの環境によるものかもしれません。 -- [[うp主]] &new{2008-12-04 (木) 11:17:58};
- 問題のプロジェクトを1〜100、101〜175など分割すれば出力自体は出来るので適当に対応します。 -- [[167]] &new{2008-12-10 (水) 21:06:52};
- 1.77de -- [[167]] &new{2008-12-19 (金) 23:30:36};
- 1.77で数回試してエラーの後、前のverでやろうとしたら「旧verで読めません」を経て再度1.77でやったら不思議とエラーでませんでした。変な事言ってますが参考までに&修正乙です -- [[167]] &new{2008-12-19 (金) 23:32:21};

#comment

**コンポジションにエコーをかけると変な動作になる [#d1df22db]
> (2008-11-26 (水) 02:30:12)~
~
コンポジションにエコーをかけるとエコーの数が5つだとしてもエコーが最後の一か所に集中します。今、エフェクトを作っているんですけど、それでも同じ現象が起きていてITimeline.GetImage()がそういうのを返しているっぽいです。~

//
- 以前愛用者スレ3の824-827で話題が出てましたね。結局うやむやになってましたが・・・。うちだとうまく動いているように見えます。サンプルプロジェクト上げてみました。ダウンロードは[[ こちらから >http://www10.uploader.jp/dl/NiVEM/NiVEM_uljp00030.zip.html]]。かけ方によるかもしれないんで、詳細な説明や再現プロジェクトなどがあるとうp主さんも解析が楽になるかもとお節介。 -- [[金の髭]] &new{2008-11-26 (水) 05:43:51};
- 確認しました。RAMプレビューが有効なときにはITimeline.GetImage()はそこからイメージをコピーして返すようになっているのですが、それが悪さをしていたようです。 -- [[うp主]] &new{2008-11-26 (水) 07:25:25};
- |ω・`) RAMプレビュー使ってなかった・・・ orz ヨケイナチャチャイレテスンマセン -- [[金の髭]] &new{2008-11-26 (水) 13:30:40};
- うp主さん確認ありがとうございました。金の髭さんも追試ありがとうございました。100%再現する方法を見つけたと思っていたもので。。。RAMプレビューは無意識にONにしていて頭の片隅にもなかったです。 --  &new{2008-11-26 (水) 23:02:42};

#comment

**v1.75の連番イメージ書き出しでSystem.NotImplementedException [#q1f6af6c]
> (2008-11-24 (月) 23:12:40)~
~
v1.75の連番イメージ書き出しでSystem.NotImplementedExceptionが発生しました。そのままスルーで実害はないようです。~

//
- 間違えました。連番イメージ読み込みです。 --  &new{2008-11-24 (月) 23:23:21};
- 確認しました。どうやらIMediaInput.GetAudio()を実装し忘れていたようです orz ちゃんとreturn null;って書いたような気がしたんだけどな… orz -- [[うp主]] &new{2008-11-25 (火) 08:36:01};

#comment

**OpenGL系の回転でリニアのキーフレームを打つとInvalidCastException(v1.75で再発生) [#rc3127e7]
>[[金の髭]] (2008-11-24 (月) 10:15:11)~
~
v1.74時に[[ こちら >バグ報告#q9253818]]で報告したバグが、v1.75でも発生するようです。~
readme.txtを見るとv1.75で修正対象だったようなのでビルドミスの可能性も?~
念のためエラーログを上げておきました。~

//
- 確認しました。 また別の場所でキャストミスがあったようです。検索掛けたんだけどな… orz -- [[うp主]] &new{2008-11-24 (月) 11:47:10};

#comment

**avi書き出し中にエラーになります。 [#i7ca805c]
>[[たわ]] (2008-11-24 (月) 07:27:47)~
~
v1.75を使用しています。~
DSVideoInputで4GbyteのAVIを5つ以上読込み、VFWOutputを行うと~
数フレーム出力しただけでエラーとなります。~
同様のファイルをVFWInputで読込んで(2Gbyteまでしか読込めませんが)、~
VFWOutputを行ってもエラーにはなりませんでした。~
エラーログをアプロダに上げておきます。~

//
- エラーログを見てみましたが、ちょっといやな場所でエラーが出てますね… そのAVIの画面サイズはどのくらいでしょうか? -- [[うp主]] &new{2008-11-24 (月) 11:45:45};
- AVIの画面サイズは1280 x 720でフレームレートは60fpsとなります。 -- [[たわ]] &new{2008-11-24 (月) 20:01:20};

#comment

**WaveOutputができない [#wa3030ce]
>[[金の髭]] (2008-11-19 (水) 21:13:23)~
~
v1.75使用。WaveOutputができなくなっているようです。~
  書き込み中にエラーが発生しました。~
  メソッドまたは操作は実装されていません。~
という警告ウィンドウがでます。v1.74では問題ありませんでした。~
使ったのはWaveInputで読み込んだPCM 44100Hz 2ch のwaveファイルです。~
エラーログをアプロダに上げておきました。~

//
- 確認しました。書き出し処理を少しいじったときにいらないところまでいじってしまったようです orz -- [[うp主]] &new{2008-11-20 (木) 18:49:53};

#comment

**参照型エフェクトを使ったトラックをコピーしてからアンドゥしていくとTargetInvocationException [#r1707e1f]
>[[金の髭]] (2008-11-19 (水) 17:50:29)~
~
v1.75使用。以下再現手順です。~
 1.新規プロジェクト作成→カラーイメージを作成→タイムラインに追加。~
 2.参照型エフェクト(除外やトラックマットなど)をかけ、参照トラックを指定。~
 3.トラックをコピーして貼り付け。~
 4.アンドゥしていくと、最初のトラック追加をアンドゥしようとした際にTargetInvocationExceptionが発生。~
エラーログをアプロダに上げてあります。~

//
- 確認しました。どうやらタイムラインが空になった状態でArrayクラスのメソッドを実行しようとしたときにエラーが飛んでしまっていたようです。 -- [[うp主]] &new{2008-11-20 (木) 18:49:08};

#comment

**タイムラインがキーフレームで埋め尽くされたように見える [#v72b3a98]
>[[金の髭]] (2008-11-09 (日) 06:55:19)~
~
NiVE v1.74。些細な点ですが一応報告。以下再現手順と現象です。~
  1.タイムラインウィンドウを横に縮め、1〜15フレームまでしか表示されないサイズにする。~
  2.マテリアルの位置(なんでもよさげですが)で、1〜10フレームに10個の固定点キーを打つ。~
  3.11フレームに移動し、右クリックで全てのキーフレームを選択。10フレーム目のキーフレーム右クリックでキーフレームをコピー。~
    11フレームで貼り付け。~
  4.下のスクロールバーを動かして右にいくと、20フレーム目以降もずっとキーフレームがあるように見える。(表示だけで値には影響していない)~
  5.存在しないはずの100フレーム目あたりのキーフレームを削除すると、存在しないはずのキーフレームは全て消えるが、~
    最初のほうに戻ってみると、実在するキーフレームが1つ消えている。~
  6.消えたキーを打ち直してまた右にいくと、またキーフレームで埋め尽くされている。~
~
タイムラインウィンドウを広げれば普通に見えるので、スクロールバー関連かなと思います。~

//
- 確認しました。キーフレームの再配置はPaintイベントの中で行っているのですが、プロパティの端の方までいっぱいにキーフレームがあると、Paintイベントが発生しなくなってしまっていたようです。 -- [[うp主]] &new{2008-11-09 (日) 20:21:46};

#comment

**プロジェクトを開く際のエラー [#y8ad4e08]
>[[nanasin]] (2008-11-08 (土) 20:38:28)~
~
とあるプロジェクトを開こうとすると「キャッチされない例外 System UriFormatException」と出てしまいます。~
他のファイルは問題ないようですが、これはファイル自体が壊れてしまっているのでしょうか?~

//
- 同じ問題かどうかわかりませんが、このページの少し下にある「v1.74でファイルが見つからないとUriFormatException」という報告を参照してみて下さい。同じ問題であれば、プロジェクトに必要な素材ファイル(動画とか静止画とか音声とか)をプロジェクトと同じディレクトリに置くことで解決できる可能性があります。それでも解決しないようなら、問題のプロジェクトをアップしてうp主さんに診断してもらうしかないかと。 -- [[金の髭]] &new{2008-11-08 (土) 22:35:08};
- プロジェクトファイルを移動させたところ 読み込んでくれました。ありがとうございました。 -- [[nanasin]] &new{2008-11-09 (日) 15:39:17};

#comment

**テキストアニメータ「回転」で回転数が無効になっている [#g2a7a87b]
> (2008-11-05 (水) 05:37:35)~
~
NiVE v1.74使用。テキストアニメータの「回転」の「回転数 x 角度°」の指定で、~
"回転数"の部分が無効になっているようです。~

//
- 確認してみましたが、特に問題なく動作しています。もう少し無効になるときの状況を詳しく説明していただけますでしょうか? -- [[うp主]] &new{2008-11-05 (水) 16:53:57};
- すみません、無効という表現が悪かったかもしれません。入力値が回転の計算に使われていないように見えます。例えば1文字ずつ1回転させようとした場合、回転に「0 x 360」と指定して開始0→100にスライドすれば回ってくれますが、回転の指定が「1 x 0」の指定だと全く動きません。2回転半させたいと思って「2 x 180」と指定すると180度しか回転しません。 -- [[金の髭]] &new{2008-11-05 (水) 21:32:00};
- 確認しました。プロパティ取得時に回転数分だけ360足すのをわすれていました orz -- [[うp主]] &new{2008-11-06 (木) 22:01:24};

#comment

**OpenGL系の回転でリニアのキーフレームを打つとInvalidCastException [#q9253818]
>[[金の髭]] (2008-11-04 (火) 22:29:08)~
~
NiVE v1.74。OpenGL系で回転パラメータにキーフレームタイプ"リニア"のキーフレームを打ち、~
その後ろのフレームに移動するとInvalidCastExceptionが発生します。~
カレントフレームの手前に"リニア"のキーフレームを打っても同様です。~
OpenGLレンダラ使用時、および3Dエフェクトプラグイン使用時に確認。GDIなどは問題ないようです。~
エラーログをアプロダに上げてあります。~

//
- 確認しました。リニア補間時の最終キーフレーム以降のコピー処理でキャストをミスってました orz -- [[うp主]] &new{2008-11-05 (水) 16:53:04};

#comment

**テキストのソース・フォント・色が遅れて反映される [#vc703e88]
>[[ルーチェ]] (2008-11-02 (日) 22:03:31)~
~
v1.74にてテキストに設定したソーステキスト・フォント・色が、数フレーム遅れて反映されます。~
具体的には79フレーム目から遅れ始め、フレーム数に比例して遅れが大きくなります。~
10000フレーム目に対しては65フレームの遅れが出ていました。~
~
ただ、v1.73で作ったプロジェクトを読み込むとこの現象は発生しませんでした。~
どちらも、テキストに対して追加のエフェクト設定等をしているわけではないのですが…。~

:22:12 追記|その後、v1.73とv1.74でテキストのみのプロジェクトの作って違いを比較しようとしたのですが、再現しませんでしたorz(v1.74でも正常に反映された)~
問題の起きたファイルは、問題の無かったv1.73のファイルをコピーしてアイテムの追加・削除等の編集をしていたものなのですが、いつからこの症状が出ていたのか不明です…。
:22:40 追記|とりあえず、一旦テキストをタイムラインから消して挿入し直すことで症状は消えました。~
参考になるかわかりませんが、症状の起きているファイルをアップローダに上げておきます。~
http://www9.uploader.jp/dl/nicoAE/nicoAE_uljp00029.zip.html~
このファイルでは、数フレーム遅れるどころか、全く反映されません…。

//
- 確認しました。どうやら、イメージを取得するときに出力フレームの位置を動画のものとして計算していたため、デュレーションを変更すると取得するフレームも変わってしまっていたようです。 -- [[うp主]] &new{2008-11-04 (火) 11:09:16};

#comment

**テキストアニメータの「スケール」が0%方向にアニメーションしてしまう? [#u19c0950]
>[[金の髭]] (2008-11-01 (土) 15:26:54)~
~
NiVE v1.74使用。テキストアニメータで「スケール」を使うと、0%方向にアニメーションしてしまうようです。~
  例:先頭から1文字ずつ50%から100%に拡大させようと思い、スケール50x50指定で「開始0→100」にスライドさせると、~
    50%から徐々に0%に縮小されたあと、突然100%になるという動きをする。~
スケールは常に100%方向にアニメーションするのが自然だと思いました。~

//
- 確認しました。スケールのアニメーション時の式を間違えていたようです orz -- [[うp主]] &new{2008-11-01 (土) 21:22:42};

#comment

**v1.74でファイルが見つからないとUriFormatException [#ia1b1165]
>[[金の髭]] (2008-10-30 (木) 19:49:02)~
~
愛用者スレ4の423-427あたりに書いた件ですが、~
  【NiVEサンプル】グラデーションワイプで文字を描く~
   http://www.nicovideo.jp/watch/sm5018535~
のサンプルプロジェクトにおいて、グラデーションのbmpファイルが~
読み込めない状態でプロジェクトを開こうとするとUriFormatExceptionが発生しました。~
エラーログをこちらに上げてあります。~
   http://www9.uploader.jp/dl/nicoAE/nicoAE_uljp00025.xml.html~
~
v1.63から、ファイルが見つからなかった場合は場所を聞くようになりましたが、~
なぜかこのプロジェクトだとそれが働かずエラーになるようです。~
シンプルなプロジェクトで試すとちゃんと場所を聞いてくれるのですが・・・。~
プロジェクト側になんらかの問題があるのかもしれませんが、一応ご報告しておきます。~

//
- 確認しました。現在でもファイルの存在チェックは機能しているのですが、本来、プロジェクトのアイテムはフルパスで保存するようになっているのですが、なぜかファイル名のみになっているために該当のエラーが発生しているようです。現象の再現も試みましたが、どうやら環境依存の問題っぽいですね。一応例外処理を強化してみます。 -- [[うp主]] &new{2008-10-30 (木) 22:47:21};
- なるほど、いったい何故そんなことに・・・。最近は起きてないのですが、以前ちょくちょくアイテム名がフルパス表示になることがあったのでそのへんも絡んでるのかな・・・。対応ありがとうございました。 -- [[金の髭]] &new{2008-10-31 (金) 00:11:59};

#comment

**最終キーフレームタイプを「スプライン」にすると、その後も値が変化し続ける [#x342cb5b]
>[[金の髭]] (2008-10-28 (火) 21:48:19)~
~
愛用者スレにもちらっと書きましたが他の話題で流れ気味なので一応こちらにも。~
NiVE v1.74。いくつかキーフレームを打ち、最終キーフレームのタイプを「スプライン」にすると、その後も値が変化し続けます。~
2箇所以上にキーフレーム(タイプはなんでもよい)を打ち、その後ろのどこかでスプラインのキーフレームを打てば再現するようです。~
スプライン以外なら問題ないようです。~

//
- 確認しました。 どうやら範囲チェック部分の式を間違っていたようです orz -- [[うp主]] &new{2008-10-29 (水) 16:18:51};

#comment

**VFWImputでAvi読み込み時にAudioを読み込んでくれない [#tf52ba78]
>[[わっか]] (2008-10-25 (土) 01:58:12)~
~
NiVE 1.73 を使用させていただいてます。~
以前、NiVE 1.55を使ってた時は、~
Aviファイル(音声付)をVFWImputで読み込むと、自動的に「Video」と「Audio」~
の2種類が読み込まれたのですが、同じAviファイルをVer1.73で読み込んでやると~
「Video」しか読み込まれず、「Audio」は読み込んでくれません。~
何か操作の仕方か、設定が悪いのでしょうか?~
ちなみに音声付Aviファイル内の音はWave(PCM)です。~
助言お願いします。~

//
- 後で気づいたのですが、質問箱の方に書くべきでしたね。すみません。 -- [[わっか]] &new{2008-10-25 (土) 02:09:20};
- NiVE v1.55でもVideoとAudioは別々に読み込んでやらないといけません。元々のNiVEの仕様です。音声を別に用意してWaveInputで読み込むか、DirectShowプラグインを入れてDSAudioInputでAviから直接読み込みましょう。 --  &new{2008-10-25 (土) 05:27:38};
- ver 1.55からver 1.60にバージョンアップした際に、VFWのファイル読み込みに関する処理を変更したため、一部のaviで音声が読み込めなくなってしまった物があるようです。 上の方がすでに書いていますが、オーディオとビデオを分割して読み込むようにしてください。 -- [[うp主]] &new{2008-10-25 (土) 11:20:37};
- あ・・・一応v1.55で試してから回答したんですが使ったAVIが悪かったみたいです。音声PCMのAVIでやったらv1.55ではVideoとAudio両方作られることを確認しました。v1.73ではVideoだけになりましたが。自動的に映像音声両方作られることもあったのですね、初めて知りました。一部間違った回答をしてしまい失礼しました。 -- [[上で答えた人]] &new{2008-10-25 (土) 12:50:43};
- ご回答、どうもありがとうございました。助かりました。 -- [[わっか]] &new{2008-10-25 (土) 15:54:31};

#comment

**direct show入力プラグインがdlできない [#lddd643f]
>[[aki]] (2008-10-19 (日) 19:06:00)~
~
概要~
はじめまして。NiVEを使わせて頂こうとdlし、direct show入力プラグインを入れようとしたのですが”あなたが要求したファイルはサーバ上に存在しません。削除されたかアドレスが間違っています。”と出てしまいました・・~

//
- ここはNiVE本体のバグ報告ページですし、そもそもバグの報告ではないですね。DirecShowプラグインは一時的に消えていたものが再アップされたので今ならダウンロードできます。プラグインについての質問は、プラグインのページ一番下のコメント欄に。DirectShowプラグインが消えてた件もそこに書かれてますし。 --  &new{2008-10-19 (日) 20:11:46};

#comment

**クリップボードに厳密コピーでエラー [#t0a613f0]
>[[コーヒー]] (2008-10-15 (水) 04:54:45)~
~
エラーログ→http://www9.uploader.jp/dl/nicoAE/nicoAE_uljp00019.xml.html~
~
ver1.72にて、エクスプレッション用にスライダ(Single)で右クリックメニューからクリップボードに厳密コピーを選んだとき~
~
キャッチされない例外~
System.Runtime.InteropServices.ExternalException~
が発生しました。~
~
その後いろいろ試しましたが再現性がなかったのでよくわかりません。レンダラはGDIです。~
お時間のあるときに見てくださいませ。~

//
- どうやらこのエラーはNiVE側というよりシステム側っぽいですね。ちょっと原因が分からないので何ともいえませんが、とりあえず例外処理を挟んでみます。 -- [[うp主]] &new{2008-10-16 (木) 08:48:49};
- よろしくおねがいしますです。 -- [[コーヒー]] &new{2008-10-16 (木) 21:30:02};

#comment

**アイテム削除をしても、選択されているコンポジション以外のトラックが削除されない [#yc0413cf]
>[[TYPE-N]] (2008-10-13 (月) 21:03:36)~
~
概要)~
複数のコンポジションに同じアイテムAをトラックとして読み込んでいる時、そのアイテムAを削除しても、現在選択されているコンポジション以外のトラックは削除されていない。~
ただ、タイムラインウインドウ上に削除したアイテムのトラックが存在してる状態でファイル保存しても、プロジェクトを読み込んだ時には、削除済みアイテムのトラックは削除してくれるようで大丈夫です。~

//
- 確認しました。コンポジションを実装したときに一部のコードが古いままのため、選択されたコンポジション以外のアイテムは削除されなかったみたいです orz -- [[うp主]] &new{2008-10-16 (木) 08:47:34};

#comment

**タイムライン ウインドウ内のトラックを表示できる範囲がおかしくなる - その2 [#b7166c20]
>[[TYPE-N]] (2008-10-13 (月) 20:44:17)~
~
解り難いと思いますが、よろしくお願いします。~
~
概要)~
シャイを設定したトラックをシャイボタンで隠した後、他のコンポジションを選択や、タイムラインウインドウの最小化or最大化してから元に戻し、~
隠れているトラックをシャイボタンで表示させると、タイムラインウインドウの表示できる範囲がおかしくなる。~
~
例)30トラック読み込み済。タイムラインウインドウの高さは20トラック分。10トラックをシャイで隠し、20トラック表示あり状態。~
20トラック分のスクロールしか出来ない状態で、隠されている10トラックをシャイ表示しても、スクロールは20トラック分までしかできない。~
~
再現方法)~
1.タイムラインウインドウの表示できる限界以上のトラックを読み込む。~
(要は、スクロールバーが表示されるようにする為なので、ウインドウの高さを低くして画像アイテム20-30個程追加でOK。)~
2.タイムラインウインドウにスクロールバーが表示されたら、5〜10トラック程シャイを設定して、隠します。~
3.タイムラインウインドウを、コンポジション変更 or タイムラインウインドウ大きさ変更など、表示部分範囲の再計算をさせ(? プログラムわかりません)、スクロールバーの動く範囲が変わればOK。~
4.シャイで隠されている、トラックを表示させると。表示範囲がおかしくなる。~
~
対処法~
・タイムラインウインドウを再表示させたり、大きさを変えたりして、ウインドウ表示部分の再計算させると直る。~
 - 最大化(or最小化)して、元に戻す。~
 - 上下左右に大きくする。(大きさを変えずにタイムラインウインドウの位置を動かすだけじゃダメ)~
・シャイを表示し、他のコンポジションを選択して、戻ってくる。~
~
▼ちなみに、シャイで隠した時に、タイムラインウインドウにスクロールバーが有っても、タイムラインウインドウの一番下に余計な空白が出来ます。~
同じようにタイムラインウインドウの再描写等の計算(??)で無駄な空白は消えます。~
(タイムラインウインドウが充分大きくて、トラックが少ないからできる最下層空白とは違います。)~
~
パラパラアニメみたいなモノを作ってるので、トラック数が異様に増えてしまう自分だけの悩みだと思います。~
落ちるとかは、全く無いので緊急性はあまりないかと…。覚えていたら何かのついでにお願いします。~

//
- 確認しました。どうやら、.NET側の処理の仕様のため、コントロールを消しただけではコンテナのサイズが変わらず、スクロールバーの長さなども変更されなかったみたいです。 -- [[うp主]] &new{2008-10-16 (木) 08:46:32};

#comment

**開くと同時にエラーが出ますorz [#e380349a]
>[[hirohiro]] (2008-10-13 (月) 06:25:51)~
~
題名の通り、nvpファイルを開くと同時にエラーが出て終了となります。~
表示がおかしかった(タイムラインのコンポジションタグが青いバーで隠れる)ので、いったん閉じて開きなおそうとすると、こうなりました。~
特に変わった作業はしていないつもりなのですが・・・~

//
- エラーログを見たところ、どうやらプロジェクトが大きすぎてウインドウハンドル作成時にエラーが出ているか、プロジェクト自体が破損してしまっている可能性があります。前者の場合、自己責任となりますが、FAQに書いてある手順通りにレジストリを書き換えると読み込めることがあると思われますが、後者の場合はプロジェクトが破損してしまっているため、復旧は難しいと思われます。 -- [[うp主]] &new{2008-10-13 (月) 08:59:57};
- レジストリ書き換えを試してみましたが、無理でした。そう大きなプロジェクトではなかったので、ファイル破損だと思います。有難うございました。 -- [[hirohiro]] &new{2008-10-13 (月) 17:14:43};

#comment


トップ   新規 一覧 単語検索 最終更新   ヘルプ   最終更新のRSS