* バグ報告 [#v0b81dea]

> 使用中に発生した例外等で、エラーログをはき出せなかった場合や、エラーログをアップロードした際にご報告下さい。&br;
&size(30){&color(red){過去の報告は[[こちら>http://www.wikihouse.com/nicoAE/index.php?%A5%D0%A5%B0%CA%F3%B9%F0]]};};&br;
&br;
エラーログは ''NicoVisualEffects.exe'' があるフォルダ内に ''errorlog.xml'' という名前で保存されます。&br;
エラーが発生した場合、バージョンが最新であるかどうか確認し、最新でない場合は最新版に更新した後、再現するかどうか確認してください。&br;
ファイル読み込みやタイムラインへの配置時にエラーが発生した場合、エラーログ
の下にファイルの詳細(ツールで取得したもの)も記述して下さい。&br;
情報取得ツール:[[真空波動研>http://kurohane.net/]]、[[MMname2>http://page.freett.com/HarryTools/index.html]]&br;
エラーログのアップロードは[[こちら>http://www9.uploader.jp/home/nicoAE/]]からお願いします。&br;
&br;
書き込む前に、今までの書き込みやこちらに同じような現象がないか確認して下さい。:[[FAQ]]&br;
&br;
#article_kcaptcha
**アイテム入替でたまに NullReferenceException [#dbb01185]
>[[ルーチェ]] (2009-03-07 (土) 18:24:32)~
~
お疲れ様です。~
~
NiVE1.81…というか以前からなのですが、Imageのタイムラインで「アイテムの入れ替え」を選ぶと、たまに NullReferenceException が出ます。~
「続行」を選べば特に問題なく作業継続できるのでそこまで深刻ではないのですが、一応報告させて頂きます。~
~
画像はPNG形式ファイルをImageInputで読み込んだものしか使っておりません。~
続行後、同じタイムラインに対してアイテム入れ替えを選択すると今度は問題なく入れ替えできたりするので、特定のタイムラインというわけでもなさそうです。~
Image以外のタイムラインについては入れ替えをしたことがないのでわかりません。~
~
一応エラーログをあげておきます。~
http://www9.uploader.jp/dl/nicoAE/nicoAE_uljp00101.xml.html~
あまり役には立たなさそうですが…。~

//
- 何度か入れ替えを試してみましたが、エラーは発生しませんでした。コードを追ってもちょっとわからなかったので、とりあえず例外処理を強化して様子を見てみます。 -- [[うp主]] &new{2009-03-07 (土) 22:53:31};
- ありゃ、出ませんでしたか。一応私が入れ替えする時の手順としては、「1.既存のImageタイムラインをコピペ」「2.コピペしたタイムラインでアイテム入れ替え」となります。レンダラは拡張2Dオンリーです。次のバージョンでこの例外が出たらまたエラーログをUPしようと思います。 -- [[ルーチェ]] &new{2009-03-07 (土) 23:08:52};

#comment_kcaptcha

**開発お疲れ様です [#q73c7f29]
>[[hiro]] (2009-03-06 (金) 16:37:56)~
~
キャッチされない例外~
System.InvalidCastException~
が発生しました。~
~
初心者の質問で申し訳ないのですが、上記のエラーは私の操作ミスでしょうか?バグでしょうか?~
いちおうエラーログはうpしております。~
宜しくお願いしますm(_ _)m~

//
- 今まで使ってて発生したことがないのでちょっとわかりませんが、ログを見ると、nicoAE.PresetEffects.dllのバージョンが低いようです。これを最新のものに入れ替えてみて、同じエラーが発生するかどうか試してみてください。 -- [[うp主]] &new{2009-03-07 (土) 22:35:06};
- nicoAE.PresetEffects.dllの最新版で直りました。初歩的ミスですみませんorzありがとうございましたm(_ _)m -- [[hiro]] &new{2009-03-08 (日) 06:43:53};

#comment_kcaptcha

**カラーリマップで色相300-360がうまくリマップできない [#tb7fa06b]
>[[金の髭]] (2009-03-03 (火) 02:38:09)~
~
入力をグレースケールにリマップするカラーリマップを作ってみたのですが、~
入力を「色相」にすると、色相300-360の範囲がうまくリマップされないようです。~
結果画像は[[こちら>http://www9.uploader.jp/dl/nicoAE/nicoAE_uljp00094.jpg.html]]。再現プロジェクトを[[こちら>http://www9.uploader.jp/dl/nicoAE/nicoAE_uljp00093.zip.html]]に上げておきました。~
また、初期位相を300にするとIndexOutOfRangeExceptionが発生します。~
[[下でご報告した件>http://nicoae.if.land.to/index.php?%A5%D0%A5%B0%CA%F3%B9%F0#c0c716b9]]を考慮してリマップ1の位相を1に変えてみましたが、今度は初期位相を301にすると同じ例外が発生します。~
~
もう1点質問で恐縮なのですが、上記プロジェクトのように入力値に応じた~
グレースケールリマップを行いたい場合、リマップ1とリマップ9の位相はどのようにすべきでしょうか。~
上記ではリマップ1を「黒,位相0」、リマップ9を「白,位相360」にしているのですが、~
例えば入力を「明度」や「彩度」にしてみると、明度や彩度の最大値部分が黒くなってしまっています。~
「黒,位相0.001−白,位相360」「黒,位相0−白,位相359.999」なども試してみたのですが、~
どうしても入力最小値、入力最大値のリマップがうまくいきません。~
(入力最小値が白くなったり入力最大値が黒くなってしまい、~
 「入力最小値=黒,入力最大値=白」の状態を作れません。)~
これは[[下でご報告した件>http://nicoae.if.land.to/index.php?%A5%D0%A5%B0%CA%F3%B9%F0#c0c716b9]]に関連する問題でしょうか?~
~
追記:書いてて気づきましたが、この場合リマップ2-8は不要ですね。~
    なんでオイラはわざわざ計算して作ったんだろう。(´・ω・`)~

//
- 確認しました。エラーが飛ぶのは下で報告いただいた通りですが、300〜360の間でリマップできないのはRGB→HLSの変換式の符号を1カ所間違っていたせいでした orz -- [[うp主]] &new{2009-03-03 (火) 10:11:25};
- 拡張2Dのブレンドモードでも同じものを使っているので、たぶんそちらでも同じような現象が起きると思います orzorz -- [[うp主]] &new{2009-03-03 (火) 10:14:57};
- 確認ありがとうございます。質問のほうですが、我ながらわかりにくい文章だったので、&br;改めて[[質問用画像>http://www9.uploader.jp/dl/nicoAE/nicoAE_uljp00099.jpg.html]]と[[サンプルプロジェクト>http://www9.uploader.jp/dl/nicoAE/nicoAE_uljp00100.zip.html]]を作ってみました。&br;「入力値最大の部分が意図しないリマップになってしまうのは何故だろう?」という質問です。&br;IndexOutOfRangeの件の修正で直る問題でしたらすみません。 -- [[金の髭]] &new{2009-03-06 (金) 23:06:16};
- エラーが飛ぶのは下で報告いただいたものが原因ですが、リマップができないのは上の通り、内部のRGB←→HLSでの式が間違っていたことが原因です。このため、対策としてはサンプルプロジェクトの通り、加減算で-1してからリマップしていただくことになります。色の変化が気になる場合は、トーンカーブなどで調整すると少しよくなると思われます -- [[うp主]] &new{2009-03-07 (土) 22:31:00};
- ありがとうございます。入力が「ルミナンス」でも発生したのでRGB←→HLSとは別の問題かと思い、一応質問させていただきました。失礼しました。 -- [[金の髭]] &new{2009-03-08 (日) 07:58:34};

#comment_kcaptcha

**プレビュー時に音声の再生と画像の移動を同時に起こすとエラーになる [#b4f9a304]
>[[MAD修行者]] (2009-02-24 (火) 23:06:25)~
~
開発お疲れ様です。~
~
RAMプレビューをONにしており、音声を再生しながら画像にトランスフォームの移動のエフェクトをかけてプレビューを再生していたら、画像のトランスフォームが始まるキーフレームに到達すると、音声がこの後まったく再生されないエラーが起きます。ソフトを再起動すればまた音声が再生されます。~
またこのエラーは常に起きるわけではなく、なぜかエラーが起きないときがあります。~
~
環境は、~
OS WinXP Home~
CPU Intel PentiumD 3.0GHz~
MEMORY 1G~
となっています。~

//
- 確認してみましたが、同様の現象は確認できませんでした。該当の現象が発生したとき、エラーログは出力されるでしょうか?また、RAMプレビューOFF時、WaveOutAPI使用時などは発生するでしょうか? -- [[うp主]] &new{2009-02-26 (木) 00:47:12};
- レスが遅れてしまいました。申し訳ありません。WaveOutAPI未使用時にはエラーはありませんでした。一度RAMプレビューOFFやWaveOutAPIを外すと、エラーがなくなりました。 エラーログは出力されません。 -- [[MAD修行者]] &new{2009-03-04 (水) 20:30:17};
- ということは普段WaveOutAPIを使用していると言うことでしょうか? もしそうなのであれば、WaveOutAPIは通常の使用時においてオーディオが再生されない場合に使用するもので、若干不安定なので、使用しなくても問題ない場合は使用しないようにしてください。 -- [[うp主]] &new{2009-03-07 (土) 22:23:38};

#comment_kcaptcha

**白色を含むイメージにカラーリマップをかけ、位相を360にするとIndexOutOfRangeException [#c0c716b9]
>[[金の髭]] (2009-02-17 (火) 23:06:40)~
~
NiVE v1.81使用。内容は表題のとおりです。標準エフェクトなのでこちらでご報告します。~
エラーログは[[こちら>http://www9.uploader.jp/dl/nicoAE/nicoAE_uljp00088.xml.html]]です。~
白色([255,255,255])のカラーイメージにかければ発生しますが、少しでも色を変えると発生しません。~
白色が1ピクセルでもあると発生するようです。~

//
- 確認しました。 出力プロパティで位相0゚にポイントを置いているときに該当のエラーが発生するようです。 -- [[うp主]] &new{2009-02-19 (木) 18:00:40};

#comment_kcaptcha

**「フレームを混合」で色が変わる [#ldba2526]
>[[コーヒー]] (2009-02-12 (木) 12:07:53)~
~
バグかどうかは迷ったのですが、一応こちらに。~
「フレームを混合」でデュレーションを縮めると微妙に色が変わってしまうようです。~
~
具体例としては、~
●カラーイメージから真っ白[255, 255, 255]の適当な長さの無圧縮aviを作成~
→それをNiVEに取り込み速度1000%に圧縮~
→色置換のエフェクトのスポイトで最初のフレーム以外の色を取得すると[250, 250, 250]になっている~
→しかも置換が行われない~
といったものがあります。~
~
確認よろしくお願いいたします。~

//
- 小さめのカラーイメージを動かしたものや、動きのある動画で試してもらうとわかりやすいのですが、フレームの混合処理では、カレントフレーム±Ceiling(速度 / 100)のフレームを参照して、位置に合わせてアルファを増減させつつ合成しています。このため、カレントフレームの上には薄くなった先のフレームが重なっているため、色が変化してしまったものと思われます。現在合成処理にはGraphacsクラスを用いているため、拡張2Dと同じ処理に変更することで回避可能と思われますが、数倍重くなります。 -- [[うp主]] &new{2009-02-12 (木) 14:22:56};
- ただ、この色の変化によってなぜ色置換が働かないのかはちょっとわかりませんが… -- [[うp主]] &new{2009-02-12 (木) 14:24:08};
- 回避可能とはいえ、数倍重くなるのは現実的ではないですねえ。仕様上のTIPSとして覚えておこうと思います。FAQに入れるにも「頻繁」にぶち当たるものでもないでしょうしw 置換が効かない件はコンポジションを介してしまえば解決できるようです。内部処理の解説ありがとうございました! -- [[コーヒー]] &new{2009-02-13 (金) 07:09:12};

#comment_kcaptcha

**連番イメージのデュレーション変更・リバースでエラー [#t46cb6e7]
>[[コーヒー]] (2009-02-11 (水) 15:20:09)~
~
連投失礼します~
~
エラーログ→http://www9.uploader.jp/dl/nicoAE/nicoAE_uljp00085.xml.html~
~
ver1.80にて、19枚の連番pngを読み込みタイムラインに追加、デュレーションを「フレームを間引く」で速度50%未満まで伸ばし、さらにリバースをかけた状態でプレビューするとアイテムの終わりのフレームでキャッチされない例外~
System.IndexOutOfRangeException~
が発生しました。~
デュレーションの変更方法を変えたり、速度50%以上までの引き伸ばしだったりすると再現しないようです。~

//
- 確認しました。どうやらフレームを間引く時の処理で0フレーム未満を参照してしまっていたようです orz -- [[うp主]] &new{2009-02-12 (木) 14:16:31};
- 確認ありがとうございます。よろしくお願いしますー --  &new{2009-02-13 (金) 07:10:11};

#comment_kcaptcha

**1フレームのaviを読み込むと固まる [#t0f5615e]
>[[コーヒー]] (2009-02-11 (水) 14:55:25)~
~
開発お疲れさまです。~
~
長さが1フレームのavi形式のファイルをDSVideoInputから読み込もうとするとNiVE自体が固まってしまうようです。VFWInputから読み込むと無事読み込めますが、長さが3フレームになってるので[s][e]の部分用に特別な処理をしてるってことでしょうか?~
エラーログは出ません。~
ファイル情報の一例を以下に。~
~
512x512 24Bit 無圧縮 30.00fps 1f 188746.56kb/s~
[RIFF(AVI2.0)] 00:00:00.033 (0.033sec) / 794,668Bytes~

//
- 確認しました。見てみると、DSVideoInputのLoadFile()を実行中に止まっているので、DSVideoInput内に何かあるのかもしれません。VFWInputで読み込んだ1フレームのaviが3フレームに増えるということについてですが、VFWOutputで出力した1フレームのaviをVFWInputで読み込んでも1フレーム分にしかなりませんでした。こちらはちょっと原因がわかりませんが、一度他のソフトで書き出し直したりすると直るかもしれません。 -- [[うp主]] &new{2009-02-12 (木) 14:13:37};
- 失礼しました、DSVideoInputはtinoさんによるプラグインでしたね。さらに3フレームに伸びる件はファイル情報を貼ったaviとは別のもので、10fpsのものでした・・・ 混乱させてしまって申し訳ありませんでした(^-^;) -- [[コーヒー]] &new{2009-02-13 (金) 07:25:26};

#comment_kcaptcha

**VFWInputで作成されたAudioアイテムをタイムラインに追加するとNullReferenceException [#s8371ce4]
>[[金の髭]] (2009-02-09 (月) 16:13:29)~
~
NiVE v1.80使用。VFWInputで下記のAVIを読み込むと、VideoとAudioのアイテムが作成されたのですが、~
このうちAudioのアイテムをタイムラインに追加するとNullReferenceExceptionが発生します。~
~
 AVIファイルの情報~
  640x480 24Bit 無圧縮 30.00fps 200f 221187.84kb/s~
  PCM 48.00kHz 16Bit 2ch 1536.00kb/s~
  [RIFF(AVI1.0)] 00:00:06.666 (6.666sec) / 185,615,748Bytes~
  真空波動研SuperLite 081122 / DLL 081122~
~
エラーログを[[こちら>http://www9.uploader.jp/dl/nicoAE/nicoAE_uljp00082.xml.html]]に上げました。~

//
- 確認しました。読み込んだオーディオを専用のオーディオ入力でラップする際にデータがうまく入ってませんでした orz -- [[うp主]] &new{2009-02-09 (月) 20:23:49};

#comment_kcaptcha

**コンポジションのフレームレートと長さの範囲 [#u0c8fef8]
>[[金の髭]] (2009-02-05 (木) 00:58:24)~
~
マイナスの値が設定できてしまうようなので、範囲チェックを入れたほうがよいかも?~
サイズのほうはチェックが入っているようなので。~

//
- 確認しました。確かにこれはまずいですね。修正します。 -- [[うp主]] &new{2009-02-07 (土) 14:09:36};

#comment_kcaptcha

**シャドウコピートラックとブレンドで無限ループ [#s4201510]
>[[金の髭]] (2009-02-03 (火) 14:18:40)~
~
NiVE v1.80使用。~
以下の手順で無限ループに入り、固まってしまうようです。~
  1.シャドウコピートラック×1、カラーイメージ×1をタイムラインに追加。~
  2.シャドウコピートラックのコピー元をカラーイメージトラックにする。~
  3.カラーイメージトラックにブレンドエフェクトを適用し、対象トラックをシャドウコピートラックにする。~

//
- 確認しました。シャドウコピー同士の循環参照対策はしましたが、こちらの方はすっかり忘れてました orz -- [[うp主]] &new{2009-02-03 (火) 20:10:52};

#comment_kcaptcha

**全体的に不安定 [#a6cd8eb9]
>[[trand]] (2009-01-30 (金) 16:00:16)~
~
NiVE1.80を使用しています。~
~
現在、テキストやイメージ、音楽など30オブジェクトほど追加したタイムラインで編集を行っているのですが、~
不意のタイミングでNiVEが操作不能となり、WindowsXPごとフリーズします。~
エラーログを見ると、きまって「インデックスが配列の境界外です。」~
という文言が見えますので、なにか不安定さの手がかりになるのではと思い報告します。~
~
決った操作で落ちるのではなく、たとえばテキストオブジェクトのテキスト打っているときとか、~
キーを複数選択しようとしてだったり、メニューを選んでいるときに、というのもあり、~
この事象が発生するタイミングに関連性は見られませんでした。~
~
http://www9.uploader.jp/dl/nicoAE/nicoAE_uljp00077.xml.html~
このログはフリーズしたときのエラーログを何回かためこんだものです。~

//
- 確認しました。アニメータの基準にスペースなし文字を選択していた場合、ソーステキストの最後にスペースが混じっていると該当のエラーが発生するようです。 -- [[うp主]] &new{2009-01-30 (金) 20:03:03};

#comment_kcaptcha

**アルファチャンネルの境界値について [#o4df16a5]
>[[July]] (2009-01-30 (金) 00:03:21)~
~
NiVE1.78からアルファチャンネルとの境界値に黒縁が表示されるように~
なっていますが仕様でしょうか。(NiVE1.77では発生せず)~
~
参考に画像をアップしました。内容は白背景に白のカラーイメージを配置し、~
円の形になるようにマスクをかけています。レンダラ:OpenGL~
http://www9.uploader.jp/dl/nicoAE/nicoAE_uljp00076.png~

//
- 確認してみましたが、こちらでは確認できませんでした。 マスクを掛けたトラックの順番が下の方にあり、かつ位置が手前にある場合はアルファが0以上1未満のところが黒っぽく表示されることはありますが、これはOpenGLの仕様です。GLSLが使用できる場合、多少回避できると思われます。 -- [[うp主]] &new{2009-01-30 (金) 15:22:52};
- 当方ではJulyさんと同様の事象が確認できました。ノートPCのビデオチップはIntel945GM。OpenGL1.4なのでFBO,NPOTT,GLSL全て無効。マスク(基本図形)は上のトラックにかけています。ただしv1.77でも発生します。v1.77ではマスクの形が「四角」「円」のどちらでも発生していましたが、v1.78からは「楕円」でのみ発生します。変更履歴にある2^nリサイズとか影響してるのかな?なんにせよグラフィックスカードなどの環境依存の問題かもしれません。OpenGLレンダラについては愛用者スレ4の878〜892あたりでも環境による違いが報告されてますね。過去ログは[[こちら>http://www.geocities.jp/goldenhige/NiVE/kako/index.html]]からどうぞ。 -- [[金の髭]] &new{2009-01-30 (金) 20:14:42};
- 追記。レンダラの背景色を白にして、白のカラーイメージ1枚にマスクをかけても発生しますが、レンダラ背景を透明にして白のカラーイメージを2枚追加し、上のトラックにマスクをかけたほうが見え方が顕著です。 -- [[金の髭]] &new{2009-01-30 (金) 20:35:36};
- 1.77と1.78で処理が異なるので、単純な環境依存ではなさそうな気がしてたのですが。。。ちなみに1.78以降でも『2^nに〜』のチェックを外すと多少改善されました。 -- [[July]] &new{2009-01-31 (土) 10:24:40};
- v1.78での変更が影響している可能性は高いと思います。ただ見え方が三者三様なので環境依存の可能性もあるのかなと。なんにせよ、あとはうp主さんじゃないとわかりませんね・・・。ビデオカードやOpenGLのバージョン、OpenGLレンダラの設定状況なども書いておくと解析の参考になるかも。 -- [[金の髭]] &new{2009-01-31 (土) 11:29:04};
- 参考に環境を書いておきます。GeForce8800GT, OpenGL2.1, FBO,GLSL,NPOTT全て有効 -- [[July]] &new{2009-01-31 (土) 15:30:31};
- なんか盛大に勘違いしてた orz こちらでのテスト結果はGeForce 9600GTでver 1.77、ver 1.80ともに金の髭氏と同じでした。ver 1.78以降で変えた部分はテクスチャのリサイズ処理のみなので、NPOTTを有効にしている場合はどちらも差はないと思われます。この部分は環境依存なので、モニタのプロパティとかをいじっていると消えたりすることもあります。 -- [[うp主]] &new{2009-02-01 (日) 08:01:22};
- 環境依存のようですが、うp主さんの現象確認取れて良かったです。とりあえずエフェクトのアルファ変換を施すと対処できましたので、同じ悩みを感じている方は参考にしてみて下さい。 -- [[July]] &new{2009-02-01 (日) 11:15:38};

#comment_kcaptcha

**出力ができない [#ma5a1b01]
> (2009-01-29 (木) 09:01:15)~
~
NiVE1.80です。~
64bit Vistaという環境のせいだとは思いますが念のため報告させていただきます。~
動画の書き出しを選ぶと、通常は32bitARGB云々のエラーに答えた後、codecの選択フェーズに移ると思うのですが、上記環境ではその窓が表示されず、そこで処理が止まってしまう(ハングアップでは無く、そこで終わってしまう感じ)になってしまいます。~
レンダリング方式を三つのどれにしても同様でした。~
VPCを利用してwindows2000で利用したら問題無く動作しました。~
一応の報告ということで。~
仕様でしたら、動作情報などで動作しないむね記述あると親切かなと思いました。~

//
- こちらに64bit Vistaの環境がないため、確認ができませんが、保田の出力プラグインで書き出した場合は書き出せますでしょうか? -- [[うp主]] &new{2009-01-29 (木) 10:20:35};
- NiVE1.81です。同じ状態ですのでご報告。 -- [[hosi]] &new{2009-02-16 (月) 22:38:22};
- nvvoutputならできるようです -- [[hosi 切れた...]] &new{2009-02-16 (月) 22:42:19};
- 旧wikiの[[ここ:http://www.wikihouse.com/nicoAE/index.php?%BC%C1%CC%E4%C8%A2#s95deeca]]にあるのですが、KB938979のパッチは当ててますでしょうか?コーデック選択時に固まるということで、記載されている内容と症状が違いますが… -- [[うp主]] &new{2009-02-17 (火) 20:31:45};
- sp1適用済みですのでパッチは関係ないと考えております。 --  &new{2009-02-23 (月) 22:51:01};
- Vista環境が手持ちにないため、テストすることはできませんが、問題なく書き出せている方もいるので何か別の問題がありそうな気はしますが… うーん orz -- [[うp主]] &new{2009-02-23 (月) 23:36:28};

#comment_kcaptcha

**22fpsの壁 その他 [#o60cd98b]
>[[vroad]] (2009-01-28 (水) 13:40:18)~
~
NiVE1.80です。~
コンポジション設定のfpsを60とか120とかにすると、プレビュー22fpsの壁を越えられるようですが(30fpsとか40fpsになる)、これはもしかしてWinFormsが重いからではなく、タイマーの処理に誤りがあるからではないでしょうか?~
もしこれが真相なら、どんな速いPCを使っても22fpsを超えない理由、重いはずなのにCPU使用率が0%近いのとかも納得できます。~
~
他に~
1.GLレンダラのとき、余白ができます。(GDIと拡張2Dではできない)ビデオカードはRADEON HD 2600XT、ドライバのバージョンは8.12です。座標変換行列の設定の問題?~
2.出力中に、タイムラインがちかちか点滅します。出力する前に1フレーム目を選択していると、1フレーム→100フレーム、1フレーム、101フレームのような感じで表示されます。~
~
再現できない問題~
3.3D変形を出したらエラーログも出さずに落ちたことがありました。メモリ不足で落ちた場合でも"OutOfMemoryException"とか出るはずなんですが。~
4.背景色の変更を選択しても何も起こらなくなったことがありましたが、NiVEを再起動すると直りました。~
5.アイテム名が急に表示されなくなりましたが、NiVEを再起動すると直りました。~

//
- WinFormsが重いという理由ですが、イメージの更新速度を測定してみると、512x384のサイズのイメージで大体12〜16ms程度かかっています。ただし、これはプレビューが未表示の状態であり、コンポジションの大きさによっても変わりますし、プレビューウインドウの大きさ、NiVEのタイムラインでの処理、バックグラウンドで動いているプロセスによっても変わってしまい、そのたびに補正してると何もできなくなるので、起動時に512x384のイメージでプレビュー未表示の状態で更新速度を計測・補正し、それ以降は環境設定で手動で微調整してもらうようになっています。&br; -- [[うp主]] &new{2009-01-28 (水) 15:55:15};
- 切れた orz&br;コンポジションの設定で60fps以上で設定した場合はこの補正によりほとんどタイマは動かさずに連続更新するようになっていますが、その場合でも40〜30fps程度しか出ないということから、WinFormsがかなり重いということがわかると思います。&br;&br;その他:&br;1、2:仕様ですw 2については、プラグインのインターフェースの変更が必要になるので、現段階での修正はできませんが、ちらつくだけで実害はないので修正の予定はありません。&br;1については3Dに関する知識がほぼ皆無の状態でやっているためで、3Dの座標計算に関する部分はうp主の能力で修正不可能な部分は現段階では仕様となっています orz そのうち気がついたら直ってるかもしれませんし、直らないかもしれません。AEのように親がカメラ1→カメラ2→カメラ3→イメージ1→カメラ4→イメージ2となっていてもカメラ1にしっかりくっついてくるようなのって行列で表現できるのかな…&br;3:多分ウインドウハンドルが多すぎてエラーレポートウインドウを表示できなかったためだと思われます。大きいプロジェクトを開いたときによくあるのですが、現段階ではレジストリを操作して対処してください。詳しくは[[FAQ]]を参照。&br;4、5:こちらでは確認できなかったので、引き続きわかったことがあれば報告お願いします。 -- [[うp主]] &new{2009-01-28 (水) 15:55:47};
- 1.マテリアルで回転等を適用していないときは座標変換しないとか・・&br;2.描画処理で出力が遅くなることは?&br;3.よく見たらバージョンが最新版ではない1.21でした・・・現バージョンでは直っているかも。あまりエフェクトは追加していませんでした。&br;4.5.以降起こっていません -- [[vroad]] &new{2009-01-29 (木) 22:14:17};
- FPSは設定で調整出来るんですね。次のフレームまで時間が余っていたら待機、遅れていたらすぐ描画みたいなのはダメなんですね・・・。待機してる暇があったらエフェクト処理に時間を当てたほうがいいので -- [[vroad]] &new{2009-01-29 (木) 22:45:59};
- 1:座標変換は回転等が加わっておらず、カメラがおかれていない場合はデフォルト状態のカメラがおかれた(注視点(0, 0, 0)、位置(0, 0, 2)、視野角61.5゚)状態になっています。&br;2:こちらでテストした限りは誤差の範囲でした。再描画による出力速度の低下が気になる場合は、出力時にタイムラインウインドウを閉じておくといいでしょう。&br;3、4、5:問題なくてよかったですw&br;待機時間に描画するということについて、ぶっちゃけ30fpsなどでの待ち時間は、プレビュー更新時間を差し引くと10数ms程度しかなく、(ブラー(ガウス)を範囲5で掛けただけで50ms以上かかる)描画中はプレビューウインドウそのたもろもろが反応しなくなるため、そいつらの反応時間なども考慮すると待機時間を利用するだけ無駄なので、いまのところそういった機能を載せるような予定はありません。 -- [[うp主]] &new{2009-01-30 (金) 15:12:57};

#comment_kcaptcha

**ドロップシャドウの影をぼかすと本体がずれる? [#l19f96e7]
>[[YO]] (2009-01-21 (水) 21:14:25)~
~
NiVE 1.78を使用しています。~
ドロップシャドウエフェクトを使用して、ぼかした影を回転させると~
特定の角度で本体が動いてしまうようです。~
プロジェクトを以下の場所においておきます。~
http://www.mediafire.com/download.php?mnjimm0nxjy~

//
- 確認しました。 これは描画時のアンチエイリアスによるもので、バグというより仕様です。 一応動かないようにはできますが、陰の距離が近い場合に動きがカクカクになりますがよろしいでしょうか? -- [[うp主]] &new{2009-01-22 (木) 00:17:37};
- 回答ありがとうございます。仕様と言うことならそういうものと考えます。GIMPのドロップシャドウみたいに、距離ゼロでぼかしドロップシャドウを入れて、まわりがぼおっと光るような感じにしたいというのが元々の話だったのですが、動きがカクカクになるということであれば仕方ないかなと。 -- [[YO]] &new{2009-01-22 (木) 06:44:40};
- 周りが光っているような表現には、ドロップシャドウを陰の距離0で掛けるよりも、膨張を使って境界線をぼかした方がズレもなく、簡単に同じような表現ができると思われます。 -- [[うp主]] &new{2009-01-22 (木) 14:43:34};

#comment_kcaptcha

**トラックマットのアルファマットが2値判定 [#u47bc3d3]
>[[金の髭]] (2009-01-13 (火) 23:45:44)~
~
ちょこまかとすみません。NiVE v1.78使用。~
トラックマットでマットに「アルファ」を指定した場合、アルファ値が「0」「0以外」の2値でしか判定されていないようです。~
例えばGIMPで白から透明に変化するグラデーションを作ってアルファマットとして画像に適用したところ、~
アルファが0の部分しか表示されませんでした。~
(白から黒に変化するグラデーションをルミナンスマットとして適用した場合は~
 狙いどおりグラデーション状にマットがかかります。)~

//
- 確認しました。トラックマットは、リサイズ時にColorMatrixでマスクを作成しているのですが、行列の要素を0にし忘れたところがあったため2値判定になってしまっていたようです -- [[うp主]] &new{2009-01-14 (水) 10:04:49};

#comment_kcaptcha

**テキストからExecuteExpression()を実行した時の挙動 [#hd6cef76]
>[[金の髭]] (2009-01-13 (火) 00:04:08)~
~
NiVE v1.78使用。テキストマテリアルのエクスプレッションにExecuteExpression()を呼び出すコードを書くと、~
その後マテリアルやエフェクトのエクスプレッションを書こうとした際に例外が発生します。~
再現手順やエラーログは[[こちら>http://www9.uploader.jp/dl/nicoAE/nicoAE_uljp00069.zip.html]]にまとめて上げてあります。~
コードの書き方を間違ってるかもしれないので、もしそうならご指摘いただければ幸いです。~

//
- 確認しました。エラーレポートウインドウが出てくるのは2つ下の通りで、今回のはIExpressionComposition.ExecuteExpression()実行時に、生成したファイルからAssemblyインスタンスを作る際にFileIOPermissionが引っかかってたようです。 -- [[うp主]] &new{2009-01-13 (火) 15:43:53};

#comment_kcaptcha

**ブレンド先へのエクスプレッションが適用されない問題 [#gf71a56a]
>[[167]] (2009-01-11 (日) 12:34:37)~
~
NiVE ver1.78使用~
オブジェクトAにブレンドTエフェクト適用し、オブジェクトBをブレンド。~
Bのトランスフォームの不透明度からエクスプレッションで点滅させたが点滅せず。~
直接キーフレームを打った場合は点滅する。~
~
回避法としてAのブレンド率で点滅させれば可能ですが、バグだと思いますので報告。~

//
- 確認しました。ITimeline.GetImage()の処理部分をエクスプレッション追加時に変更し忘れてました(ずいぶん前だな) orz -- [[うp主]] &new{2009-01-12 (月) 13:54:14};

#comment_kcaptcha

**テキストとアニメータのエクスプレッションでのエラーの出方 [#g894b60a]
>[[金の髭]] (2009-01-09 (金) 00:36:16)~
~
テキストマテリアルやアニメータのエクスプレッションで、例えば~
  MonitorProperty.Add(null);~
という感じでエラーを出すと、~
  'nicoAE.Expression.ExpressionException'型のオブジェクトを~
   逆シリアル化するコンストラクタが見つかりませんでした。~
というエラーウィンドウのあと、~
  キャッチされない例外'nicoAE.Expression.ExpressionException'~
のウィンドウが出て終了か継続かを確認されます。~
一応エラーログを[[こちら>http://www9.uploader.jp/dl/nicoAE/nicoAE_uljp00068.xml.html]]に上げておきました。~
マテリアルやエフェクトのエクスプレッションでは「評価中にエラーが発生しました」と出て~
一時的にエクスプレッションが評価されなくなるだけでした。~

//
- 確認しました。テキストアニメータ関連のエクスプレッションの例外処理部分がうまく機能していないのが原因でした orz また、ExpressionExceptionでもGetObjectData等のオーバーライドし忘れがあったようです orzorz -- [[うp主]] &new{2009-01-09 (金) 13:18:48};

#comment_kcaptcha

**エクスプレッション関係で色々 [#za229c8d]
>[[金の髭]] (2008-12-29 (月) 08:54:52)~
~
1.テキストアニメータのプロパティを右クリックして「クリップボードに厳密コピー」した時の表現が一部間違っているようです。~
   ●厳密コピーした時の表現~
     ExpressionUtils.GetProperty(ExpressionUtils.GetItem(((IExpressionAnimator)Property.This),Material.GetAnimator(), 1961245682).Properties, "位置");~
  "Material"の前がピリオドではなくカンマになってしまっています。~
~
2.「エクスプレッションについて.txt」にあるExpressionUtils.GetComposition()が存在しないようです。~
  ループで回してコード比較すればいいので問題ないですが一応ご報告しておきます。~
~
3.「プラグイン開発について.txt」のStringPropertyのコンストラクタの説明で~
  defaultPropの型がboolと書かれているようです。~

//
- ぎゃぁぁぁぁあああああ orz 確認しました。 ExpressionUtils.GetComposition()はなぜかGetItemのオーバーロードになっていました orz 修正まではそちらを使用してください。 -- [[うp主]] &new{2008-12-30 (火) 02:07:49};

#comment_kcaptcha

**書き出し時にエラー [#r78b5079]
>[[lake]] (2008-12-24 (水) 14:25:19)~
~
エラーログ→http://www9.uploader.jp/dl/nicoAE/nicoAE_uljp00062.xml.html~
1.77で動画をDivXで書き出そうと思ったらなぜか失敗します~
~
情報不足かもしれませんが原因がよくわからないので~
確認をお願いします~

//
- XviDでもあるようなのですが、VFWOutputではいくつかのコーデックでのAVIの書き出しができないようです。一度別のコーデックか、無圧縮で書き出してAVIUtlなどで圧縮するようにしてください。 -- [[うp主]] &new{2008-12-24 (水) 21:05:25};
- わかりました ありがとうございます -- [[lake]] &new{2008-12-25 (木) 15:02:56};

#comment_kcaptcha

**読み込み済みアイテムを読み込んだ後保存できなくなる [#h974b4cd]
>[[コーヒー]] (2008-12-16 (火) 09:57:32)~
~
いつも使わせていただいております。~
~
エラーログ→http://www9.uploader.jp/dl/nicoAE/nicoAE_uljp00060.xml.html~
~
ver1.77にて、ImageInputから1枚の画像を取り込み、その後その画像を含む複数枚の画像を取り込み、「すでに開かれています」のエラーメッセージが出て残りの画像が読み込まれた段階で保存しようとすると~
System.ArgumentException~
が発生しました。~
保存は実行されないようなので、これはちょっとコワいかも・・・。~
~
確認よろしくお願いいたします。~

//
- 確認しました。複数同時読み込み時にすでに読み込んだファイルがあると、その手前の入力プラグインをDisposeしてしまっていました orz -- [[うp主]] &new{2008-12-16 (火) 20:21:45};

#comment_kcaptcha

**テキストプリセットが保存されない問題 [#wbb941f1]
>[[167]] (2008-12-10 (水) 21:17:17)~
~
ver1.76使用。~
プロジェクトによっては、テキストプリセットを保存して閉じて、再度開くと~
アイテム欄自体からテキストプリセットが消えてしまいます。~
ハッシュ値MD5でチェック。~
■保存されないプロジェクト~
追加前~
23e82d75247a17a7bc99e981ecfb1888~
~
アイテム欄にテキストプリセットを追加して保存~
2f0e2f09bf3e2260e549b5b289ffb458~
~
NiVE閉じる~
2f0e2f09bf3e2260e549b5b289ffb458~
~
NiVE開く(テキストプリセットが消えている)~
2f0e2f09bf3e2260e549b5b289ffb458~
~
■保存されるプロジェクト~
追加前~
04a8a12ac0c2bd694eb972912609c92e~
~
テキスト追加して保存~
23f0b43892a7f517ddfa2d8eea6f0f93~
~
閉じる~
23f0b43892a7f517ddfa2d8eea6f0f93~
~
開く~
23f0b43892a7f517ddfa2d8eea6f0f93~
~
再度開く際に問題の模様です。~
なお問題のプロジェクトでも動作中の作業自体は可能です。~

//
- 上の2つのプロジェクト http://www9.uploader.jp/dl/nicoAE/nicoAE_uljp00053.zip.html -- [[167]] &new{2008-12-10 (水) 21:24:23};
- 確認しました。 どうやら、カメラを先に作成してからテキストを作成すると保存はされますが、読み込み時にテキストはすでに読み込まれたものとして処理されてしまっていたようです orz -- [[うp主]] &new{2008-12-11 (木) 00:14:36};
- 1.77で修正ありがとうございます。 -- [[167]] &new{2008-12-14 (日) 00:11:42};

#comment_kcaptcha

**音声アイテムの入れ替えでエラー [#he333eb5]
>[[コーヒー]] (2008-12-03 (水) 04:52:55)~
~
エラーログ→http://www9.uploader.jp/dl/nicoAE/nicoAE_uljp00052.xml.html~
~
ver1.76にて、タイムラインの音声アイテムを「アイテムの入れ替え」で入れ替える際、候補の中にcompのアイテムも挙げられていて、それを選択すると~
System.InvalidCastException~
が発生しました。~
以前Videoアイテムの入れ替えであったのと似たような感じでしょうか。~
確認よろしくお願いします。~

//
- 確認しました。 入れ替えできるアイテムの抽出時の条件があいまいだったために洗濯できないアイテムまで選択できるようになってしまっていました -- [[うp主]] &new{2008-12-04 (木) 09:32:10};

#comment_kcaptcha

**出力時エラー [#n5403eac]
>[[167]] (2008-11-27 (木) 21:14:54)~
~
NiVe1.74〜1.76で確認。~
640×480 30fpsの175frのプロジェクトの途中で書き込み中にエラーが発生。~
種類'System.OutOfMEmoryException'の例外がスローされましたとなります。~
http://www9.uploader.jp/dl/nicoAE/nicoAE_uljp00048.xml.html~
最後の数フレームがない状態のものが出力されてしまう状態です。~
カラーイメージだけの300frで試したものは問題なく出力されます。~
自分では区別付かないので、↓のたわさんと同様の内容でしたらすいません。~

//
- エラーログからするとちょっと違いますね。場所は似たようなところだけど… どちらもまだ再現できてないので原因はつかめてません。旧wikiにある1.73以前だとどうでしょうか? -- [[うp主]] &new{2008-11-28 (金) 20:44:59};
- 問題のプロジェクトは、古いverで対応してませんと出てしまいました。 -- [[167]] &new{2008-11-30 (日) 22:19:51};
- うーん… では、コンポジションの構成とかはどうなっていますか?他にいくつかOpenGLなコンポジションとかもネストしてますでしょうか? -- [[うp主]] &new{2008-12-02 (火) 13:23:58};
- ネストと言うのは出力するコンポに、他のコンポが含まれるかという意味であってますか?出力するOpenGLのコンポの中に他のOpenGLのコンポが3個とGDIのコンポが2個含まれます。ググってもプログラム用語やら釣り用語ばかりなので、間違ってましたらお手数ですが、指示いただけると助かります。 -- [[167]] &new{2008-12-02 (火) 19:57:30};
- 中々再現しない… orz そういえば昔うpされていたサンプル(sm4546125)のプロジェクトを実行したときにまれに同じようなエラーを見た気がしたので再度実行してみましたが、グラボを積み替えていたのも合ってか再現できず。 もしかしたらPCの環境によるものかもしれません。 -- [[うp主]] &new{2008-12-04 (木) 11:17:58};
- 問題のプロジェクトを1〜100、101〜175など分割すれば出力自体は出来るので適当に対応します。 -- [[167]] &new{2008-12-10 (水) 21:06:52};
- 1.77de -- [[167]] &new{2008-12-19 (金) 23:30:36};
- 1.77で数回試してエラーの後、前のverでやろうとしたら「旧verで読めません」を経て再度1.77でやったら不思議とエラーでませんでした。変な事言ってますが参考までに&修正乙です -- [[167]] &new{2008-12-19 (金) 23:32:21};

#comment_kcaptcha

**コンポジションにエコーをかけると変な動作になる [#d1df22db]
> (2008-11-26 (水) 02:30:12)~
~
コンポジションにエコーをかけるとエコーの数が5つだとしてもエコーが最後の一か所に集中します。今、エフェクトを作っているんですけど、それでも同じ現象が起きていてITimeline.GetImage()がそういうのを返しているっぽいです。~

//
- 以前愛用者スレ3の824-827で話題が出てましたね。結局うやむやになってましたが・・・。うちだとうまく動いているように見えます。サンプルプロジェクト上げてみました。ダウンロードは[[ こちらから >http://www10.uploader.jp/dl/NiVEM/NiVEM_uljp00030.zip.html]]。かけ方によるかもしれないんで、詳細な説明や再現プロジェクトなどがあるとうp主さんも解析が楽になるかもとお節介。 -- [[金の髭]] &new{2008-11-26 (水) 05:43:51};
- 確認しました。RAMプレビューが有効なときにはITimeline.GetImage()はそこからイメージをコピーして返すようになっているのですが、それが悪さをしていたようです。 -- [[うp主]] &new{2008-11-26 (水) 07:25:25};
- |ω・`) RAMプレビュー使ってなかった・・・ orz ヨケイナチャチャイレテスンマセン -- [[金の髭]] &new{2008-11-26 (水) 13:30:40};
- うp主さん確認ありがとうございました。金の髭さんも追試ありがとうございました。100%再現する方法を見つけたと思っていたもので。。。RAMプレビューは無意識にONにしていて頭の片隅にもなかったです。 --  &new{2008-11-26 (水) 23:02:42};

#comment_kcaptcha

**v1.75の連番イメージ書き出しでSystem.NotImplementedException [#q1f6af6c]
> (2008-11-24 (月) 23:12:40)~
~
v1.75の連番イメージ書き出しでSystem.NotImplementedExceptionが発生しました。そのままスルーで実害はないようです。~

//
- 間違えました。連番イメージ読み込みです。 --  &new{2008-11-24 (月) 23:23:21};
- 確認しました。どうやらIMediaInput.GetAudio()を実装し忘れていたようです orz ちゃんとreturn null;って書いたような気がしたんだけどな… orz -- [[うp主]] &new{2008-11-25 (火) 08:36:01};

#comment_kcaptcha

**OpenGL系の回転でリニアのキーフレームを打つとInvalidCastException(v1.75で再発生) [#rc3127e7]
>[[金の髭]] (2008-11-24 (月) 10:15:11)~
~
v1.74時に[[ こちら >バグ報告#q9253818]]で報告したバグが、v1.75でも発生するようです。~
readme.txtを見るとv1.75で修正対象だったようなのでビルドミスの可能性も?~
念のためエラーログを上げておきました。~

//
- 確認しました。 また別の場所でキャストミスがあったようです。検索掛けたんだけどな… orz -- [[うp主]] &new{2008-11-24 (月) 11:47:10};

#comment_kcaptcha

**avi書き出し中にエラーになります。 [#i7ca805c]
>[[たわ]] (2008-11-24 (月) 07:27:47)~
~
v1.75を使用しています。~
DSVideoInputで4GbyteのAVIを5つ以上読込み、VFWOutputを行うと~
数フレーム出力しただけでエラーとなります。~
同様のファイルをVFWInputで読込んで(2Gbyteまでしか読込めませんが)、~
VFWOutputを行ってもエラーにはなりませんでした。~
エラーログをアプロダに上げておきます。~

//
- エラーログを見てみましたが、ちょっといやな場所でエラーが出てますね… そのAVIの画面サイズはどのくらいでしょうか? -- [[うp主]] &new{2008-11-24 (月) 11:45:45};
- AVIの画面サイズは1280 x 720でフレームレートは60fpsとなります。 -- [[たわ]] &new{2008-11-24 (月) 20:01:20};

#comment_kcaptcha

**WaveOutputができない [#wa3030ce]
>[[金の髭]] (2008-11-19 (水) 21:13:23)~
~
v1.75使用。WaveOutputができなくなっているようです。~
  書き込み中にエラーが発生しました。~
  メソッドまたは操作は実装されていません。~
という警告ウィンドウがでます。v1.74では問題ありませんでした。~
使ったのはWaveInputで読み込んだPCM 44100Hz 2ch のwaveファイルです。~
エラーログをアプロダに上げておきました。~

//
- 確認しました。書き出し処理を少しいじったときにいらないところまでいじってしまったようです orz -- [[うp主]] &new{2008-11-20 (木) 18:49:53};

#comment_kcaptcha

**参照型エフェクトを使ったトラックをコピーしてからアンドゥしていくとTargetInvocationException [#r1707e1f]
>[[金の髭]] (2008-11-19 (水) 17:50:29)~
~
v1.75使用。以下再現手順です。~
 1.新規プロジェクト作成→カラーイメージを作成→タイムラインに追加。~
 2.参照型エフェクト(除外やトラックマットなど)をかけ、参照トラックを指定。~
 3.トラックをコピーして貼り付け。~
 4.アンドゥしていくと、最初のトラック追加をアンドゥしようとした際にTargetInvocationExceptionが発生。~
エラーログをアプロダに上げてあります。~

//
- 確認しました。どうやらタイムラインが空になった状態でArrayクラスのメソッドを実行しようとしたときにエラーが飛んでしまっていたようです。 -- [[うp主]] &new{2008-11-20 (木) 18:49:08};

#comment_kcaptcha

**タイムラインがキーフレームで埋め尽くされたように見える [#v72b3a98]
>[[金の髭]] (2008-11-09 (日) 06:55:19)~
~
NiVE v1.74。些細な点ですが一応報告。以下再現手順と現象です。~
  1.タイムラインウィンドウを横に縮め、1〜15フレームまでしか表示されないサイズにする。~
  2.マテリアルの位置(なんでもよさげですが)で、1〜10フレームに10個の固定点キーを打つ。~
  3.11フレームに移動し、右クリックで全てのキーフレームを選択。10フレーム目のキーフレーム右クリックでキーフレームをコピー。~
    11フレームで貼り付け。~
  4.下のスクロールバーを動かして右にいくと、20フレーム目以降もずっとキーフレームがあるように見える。(表示だけで値には影響していない)~
  5.存在しないはずの100フレーム目あたりのキーフレームを削除すると、存在しないはずのキーフレームは全て消えるが、~
    最初のほうに戻ってみると、実在するキーフレームが1つ消えている。~
  6.消えたキーを打ち直してまた右にいくと、またキーフレームで埋め尽くされている。~
~
タイムラインウィンドウを広げれば普通に見えるので、スクロールバー関連かなと思います。~

//
- 確認しました。キーフレームの再配置はPaintイベントの中で行っているのですが、プロパティの端の方までいっぱいにキーフレームがあると、Paintイベントが発生しなくなってしまっていたようです。 -- [[うp主]] &new{2008-11-09 (日) 20:21:46};

#comment_kcaptcha

**プロジェクトを開く際のエラー [#y8ad4e08]
>[[nanasin]] (2008-11-08 (土) 20:38:28)~
~
とあるプロジェクトを開こうとすると「キャッチされない例外 System UriFormatException」と出てしまいます。~
他のファイルは問題ないようですが、これはファイル自体が壊れてしまっているのでしょうか?~

//
- 同じ問題かどうかわかりませんが、このページの少し下にある「v1.74でファイルが見つからないとUriFormatException」という報告を参照してみて下さい。同じ問題であれば、プロジェクトに必要な素材ファイル(動画とか静止画とか音声とか)をプロジェクトと同じディレクトリに置くことで解決できる可能性があります。それでも解決しないようなら、問題のプロジェクトをアップしてうp主さんに診断してもらうしかないかと。 -- [[金の髭]] &new{2008-11-08 (土) 22:35:08};
- プロジェクトファイルを移動させたところ 読み込んでくれました。ありがとうございました。 -- [[nanasin]] &new{2008-11-09 (日) 15:39:17};

#comment_kcaptcha

**テキストアニメータ「回転」で回転数が無効になっている [#g2a7a87b]
> (2008-11-05 (水) 05:37:35)~
~
NiVE v1.74使用。テキストアニメータの「回転」の「回転数 x 角度°」の指定で、~
"回転数"の部分が無効になっているようです。~

//
- 確認してみましたが、特に問題なく動作しています。もう少し無効になるときの状況を詳しく説明していただけますでしょうか? -- [[うp主]] &new{2008-11-05 (水) 16:53:57};
- すみません、無効という表現が悪かったかもしれません。入力値が回転の計算に使われていないように見えます。例えば1文字ずつ1回転させようとした場合、回転に「0 x 360」と指定して開始0→100にスライドすれば回ってくれますが、回転の指定が「1 x 0」の指定だと全く動きません。2回転半させたいと思って「2 x 180」と指定すると180度しか回転しません。 -- [[金の髭]] &new{2008-11-05 (水) 21:32:00};
- 確認しました。プロパティ取得時に回転数分だけ360足すのをわすれていました orz -- [[うp主]] &new{2008-11-06 (木) 22:01:24};

#comment_kcaptcha

**OpenGL系の回転でリニアのキーフレームを打つとInvalidCastException [#q9253818]
>[[金の髭]] (2008-11-04 (火) 22:29:08)~
~
NiVE v1.74。OpenGL系で回転パラメータにキーフレームタイプ"リニア"のキーフレームを打ち、~
その後ろのフレームに移動するとInvalidCastExceptionが発生します。~
カレントフレームの手前に"リニア"のキーフレームを打っても同様です。~
OpenGLレンダラ使用時、および3Dエフェクトプラグイン使用時に確認。GDIなどは問題ないようです。~
エラーログをアプロダに上げてあります。~

//
- 確認しました。リニア補間時の最終キーフレーム以降のコピー処理でキャストをミスってました orz -- [[うp主]] &new{2008-11-05 (水) 16:53:04};

#comment_kcaptcha

**テキストのソース・フォント・色が遅れて反映される [#vc703e88]
>[[ルーチェ]] (2008-11-02 (日) 22:03:31)~
~
v1.74にてテキストに設定したソーステキスト・フォント・色が、数フレーム遅れて反映されます。~
具体的には79フレーム目から遅れ始め、フレーム数に比例して遅れが大きくなります。~
10000フレーム目に対しては65フレームの遅れが出ていました。~
~
ただ、v1.73で作ったプロジェクトを読み込むとこの現象は発生しませんでした。~
どちらも、テキストに対して追加のエフェクト設定等をしているわけではないのですが…。~

:22:12 追記|その後、v1.73とv1.74でテキストのみのプロジェクトの作って違いを比較しようとしたのですが、再現しませんでしたorz(v1.74でも正常に反映された)~
問題の起きたファイルは、問題の無かったv1.73のファイルをコピーしてアイテムの追加・削除等の編集をしていたものなのですが、いつからこの症状が出ていたのか不明です…。
:22:40 追記|とりあえず、一旦テキストをタイムラインから消して挿入し直すことで症状は消えました。~
参考になるかわかりませんが、症状の起きているファイルをアップローダに上げておきます。~
http://www9.uploader.jp/dl/nicoAE/nicoAE_uljp00029.zip.html~
このファイルでは、数フレーム遅れるどころか、全く反映されません…。

//
- 確認しました。どうやら、イメージを取得するときに出力フレームの位置を動画のものとして計算していたため、デュレーションを変更すると取得するフレームも変わってしまっていたようです。 -- [[うp主]] &new{2008-11-04 (火) 11:09:16};

#comment_kcaptcha

**テキストアニメータの「スケール」が0%方向にアニメーションしてしまう? [#u19c0950]
>[[金の髭]] (2008-11-01 (土) 15:26:54)~
~
NiVE v1.74使用。テキストアニメータで「スケール」を使うと、0%方向にアニメーションしてしまうようです。~
  例:先頭から1文字ずつ50%から100%に拡大させようと思い、スケール50x50指定で「開始0→100」にスライドさせると、~
    50%から徐々に0%に縮小されたあと、突然100%になるという動きをする。~
スケールは常に100%方向にアニメーションするのが自然だと思いました。~

//
- 確認しました。スケールのアニメーション時の式を間違えていたようです orz -- [[うp主]] &new{2008-11-01 (土) 21:22:42};

#comment_kcaptcha

**v1.74でファイルが見つからないとUriFormatException [#ia1b1165]
>[[金の髭]] (2008-10-30 (木) 19:49:02)~
~
愛用者スレ4の423-427あたりに書いた件ですが、~
  【NiVEサンプル】グラデーションワイプで文字を描く~
   http://www.nicovideo.jp/watch/sm5018535~
のサンプルプロジェクトにおいて、グラデーションのbmpファイルが~
読み込めない状態でプロジェクトを開こうとするとUriFormatExceptionが発生しました。~
エラーログをこちらに上げてあります。~
   http://www9.uploader.jp/dl/nicoAE/nicoAE_uljp00025.xml.html~
~
v1.63から、ファイルが見つからなかった場合は場所を聞くようになりましたが、~
なぜかこのプロジェクトだとそれが働かずエラーになるようです。~
シンプルなプロジェクトで試すとちゃんと場所を聞いてくれるのですが・・・。~
プロジェクト側になんらかの問題があるのかもしれませんが、一応ご報告しておきます。~

//
- 確認しました。現在でもファイルの存在チェックは機能しているのですが、本来、プロジェクトのアイテムはフルパスで保存するようになっているのですが、なぜかファイル名のみになっているために該当のエラーが発生しているようです。現象の再現も試みましたが、どうやら環境依存の問題っぽいですね。一応例外処理を強化してみます。 -- [[うp主]] &new{2008-10-30 (木) 22:47:21};
- なるほど、いったい何故そんなことに・・・。最近は起きてないのですが、以前ちょくちょくアイテム名がフルパス表示になることがあったのでそのへんも絡んでるのかな・・・。対応ありがとうございました。 -- [[金の髭]] &new{2008-10-31 (金) 00:11:59};

#comment_kcaptcha

**最終キーフレームタイプを「スプライン」にすると、その後も値が変化し続ける [#x342cb5b]
>[[金の髭]] (2008-10-28 (火) 21:48:19)~
~
愛用者スレにもちらっと書きましたが他の話題で流れ気味なので一応こちらにも。~
NiVE v1.74。いくつかキーフレームを打ち、最終キーフレームのタイプを「スプライン」にすると、その後も値が変化し続けます。~
2箇所以上にキーフレーム(タイプはなんでもよい)を打ち、その後ろのどこかでスプラインのキーフレームを打てば再現するようです。~
スプライン以外なら問題ないようです。~

//
- 確認しました。 どうやら範囲チェック部分の式を間違っていたようです orz -- [[うp主]] &new{2008-10-29 (水) 16:18:51};

#comment_kcaptcha

**VFWImputでAvi読み込み時にAudioを読み込んでくれない [#tf52ba78]
>[[わっか]] (2008-10-25 (土) 01:58:12)~
~
NiVE 1.73 を使用させていただいてます。~
以前、NiVE 1.55を使ってた時は、~
Aviファイル(音声付)をVFWImputで読み込むと、自動的に「Video」と「Audio」~
の2種類が読み込まれたのですが、同じAviファイルをVer1.73で読み込んでやると~
「Video」しか読み込まれず、「Audio」は読み込んでくれません。~
何か操作の仕方か、設定が悪いのでしょうか?~
ちなみに音声付Aviファイル内の音はWave(PCM)です。~
助言お願いします。~

//
- 後で気づいたのですが、質問箱の方に書くべきでしたね。すみません。 -- [[わっか]] &new{2008-10-25 (土) 02:09:20};
- NiVE v1.55でもVideoとAudioは別々に読み込んでやらないといけません。元々のNiVEの仕様です。音声を別に用意してWaveInputで読み込むか、DirectShowプラグインを入れてDSAudioInputでAviから直接読み込みましょう。 --  &new{2008-10-25 (土) 05:27:38};
- ver 1.55からver 1.60にバージョンアップした際に、VFWのファイル読み込みに関する処理を変更したため、一部のaviで音声が読み込めなくなってしまった物があるようです。 上の方がすでに書いていますが、オーディオとビデオを分割して読み込むようにしてください。 -- [[うp主]] &new{2008-10-25 (土) 11:20:37};
- あ・・・一応v1.55で試してから回答したんですが使ったAVIが悪かったみたいです。音声PCMのAVIでやったらv1.55ではVideoとAudio両方作られることを確認しました。v1.73ではVideoだけになりましたが。自動的に映像音声両方作られることもあったのですね、初めて知りました。一部間違った回答をしてしまい失礼しました。 -- [[上で答えた人]] &new{2008-10-25 (土) 12:50:43};
- ご回答、どうもありがとうございました。助かりました。 -- [[わっか]] &new{2008-10-25 (土) 15:54:31};

#comment_kcaptcha

**direct show入力プラグインがdlできない [#lddd643f]
>[[aki]] (2008-10-19 (日) 19:06:00)~
~
概要~
はじめまして。NiVEを使わせて頂こうとdlし、direct show入力プラグインを入れようとしたのですが”あなたが要求したファイルはサーバ上に存在しません。削除されたかアドレスが間違っています。”と出てしまいました・・~

//
- ここはNiVE本体のバグ報告ページですし、そもそもバグの報告ではないですね。DirecShowプラグインは一時的に消えていたものが再アップされたので今ならダウンロードできます。プラグインについての質問は、プラグインのページ一番下のコメント欄に。DirectShowプラグインが消えてた件もそこに書かれてますし。 --  &new{2008-10-19 (日) 20:11:46};

#comment_kcaptcha

**クリップボードに厳密コピーでエラー [#t0a613f0]
>[[コーヒー]] (2008-10-15 (水) 04:54:45)~
~
エラーログ→http://www9.uploader.jp/dl/nicoAE/nicoAE_uljp00019.xml.html~
~
ver1.72にて、エクスプレッション用にスライダ(Single)で右クリックメニューからクリップボードに厳密コピーを選んだとき~
~
キャッチされない例外~
System.Runtime.InteropServices.ExternalException~
が発生しました。~
~
その後いろいろ試しましたが再現性がなかったのでよくわかりません。レンダラはGDIです。~
お時間のあるときに見てくださいませ。~

//
- どうやらこのエラーはNiVE側というよりシステム側っぽいですね。ちょっと原因が分からないので何ともいえませんが、とりあえず例外処理を挟んでみます。 -- [[うp主]] &new{2008-10-16 (木) 08:48:49};
- よろしくおねがいしますです。 -- [[コーヒー]] &new{2008-10-16 (木) 21:30:02};

#comment_kcaptcha

**アイテム削除をしても、選択されているコンポジション以外のトラックが削除されない [#yc0413cf]
>[[TYPE-N]] (2008-10-13 (月) 21:03:36)~
~
概要)~
複数のコンポジションに同じアイテムAをトラックとして読み込んでいる時、そのアイテムAを削除しても、現在選択されているコンポジション以外のトラックは削除されていない。~
ただ、タイムラインウインドウ上に削除したアイテムのトラックが存在してる状態でファイル保存しても、プロジェクトを読み込んだ時には、削除済みアイテムのトラックは削除してくれるようで大丈夫です。~

//
- 確認しました。コンポジションを実装したときに一部のコードが古いままのため、選択されたコンポジション以外のアイテムは削除されなかったみたいです orz -- [[うp主]] &new{2008-10-16 (木) 08:47:34};

#comment_kcaptcha

**タイムライン ウインドウ内のトラックを表示できる範囲がおかしくなる - その2 [#b7166c20]
>[[TYPE-N]] (2008-10-13 (月) 20:44:17)~
~
解り難いと思いますが、よろしくお願いします。~
~
概要)~
シャイを設定したトラックをシャイボタンで隠した後、他のコンポジションを選択や、タイムラインウインドウの最小化or最大化してから元に戻し、~
隠れているトラックをシャイボタンで表示させると、タイムラインウインドウの表示できる範囲がおかしくなる。~
~
例)30トラック読み込み済。タイムラインウインドウの高さは20トラック分。10トラックをシャイで隠し、20トラック表示あり状態。~
20トラック分のスクロールしか出来ない状態で、隠されている10トラックをシャイ表示しても、スクロールは20トラック分までしかできない。~
~
再現方法)~
1.タイムラインウインドウの表示できる限界以上のトラックを読み込む。~
(要は、スクロールバーが表示されるようにする為なので、ウインドウの高さを低くして画像アイテム20-30個程追加でOK。)~
2.タイムラインウインドウにスクロールバーが表示されたら、5〜10トラック程シャイを設定して、隠します。~
3.タイムラインウインドウを、コンポジション変更 or タイムラインウインドウ大きさ変更など、表示部分範囲の再計算をさせ(? プログラムわかりません)、スクロールバーの動く範囲が変わればOK。~
4.シャイで隠されている、トラックを表示させると。表示範囲がおかしくなる。~
~
対処法~
・タイムラインウインドウを再表示させたり、大きさを変えたりして、ウインドウ表示部分の再計算させると直る。~
 - 最大化(or最小化)して、元に戻す。~
 - 上下左右に大きくする。(大きさを変えずにタイムラインウインドウの位置を動かすだけじゃダメ)~
・シャイを表示し、他のコンポジションを選択して、戻ってくる。~
~
▼ちなみに、シャイで隠した時に、タイムラインウインドウにスクロールバーが有っても、タイムラインウインドウの一番下に余計な空白が出来ます。~
同じようにタイムラインウインドウの再描写等の計算(??)で無駄な空白は消えます。~
(タイムラインウインドウが充分大きくて、トラックが少ないからできる最下層空白とは違います。)~
~
パラパラアニメみたいなモノを作ってるので、トラック数が異様に増えてしまう自分だけの悩みだと思います。~
落ちるとかは、全く無いので緊急性はあまりないかと…。覚えていたら何かのついでにお願いします。~

//
- 確認しました。どうやら、.NET側の処理の仕様のため、コントロールを消しただけではコンテナのサイズが変わらず、スクロールバーの長さなども変更されなかったみたいです。 -- [[うp主]] &new{2008-10-16 (木) 08:46:32};

#comment_kcaptcha

**開くと同時にエラーが出ますorz [#e380349a]
>[[hirohiro]] (2008-10-13 (月) 06:25:51)~
~
題名の通り、nvpファイルを開くと同時にエラーが出て終了となります。~
表示がおかしかった(タイムラインのコンポジションタグが青いバーで隠れる)ので、いったん閉じて開きなおそうとすると、こうなりました。~
特に変わった作業はしていないつもりなのですが・・・~

//
- エラーログを見たところ、どうやらプロジェクトが大きすぎてウインドウハンドル作成時にエラーが出ているか、プロジェクト自体が破損してしまっている可能性があります。前者の場合、自己責任となりますが、FAQに書いてある手順通りにレジストリを書き換えると読み込めることがあると思われますが、後者の場合はプロジェクトが破損してしまっているため、復旧は難しいと思われます。 -- [[うp主]] &new{2008-10-13 (月) 08:59:57};
- レジストリ書き換えを試してみましたが、無理でした。そう大きなプロジェクトではなかったので、ファイル破損だと思います。有難うございました。 -- [[hirohiro]] &new{2008-10-13 (月) 17:14:43};

#comment_kcaptcha


トップ   新規 一覧 単語検索 最終更新   ヘルプ   最終更新のRSS